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Brief overview of the interface

Main sections of the program:

•

Menu: entry to the main program menu (settings, catalogs, help, language, etc.)

•

Label Printing: label printing section

•

Label Designer: label template designer (create templates, modify existing ones)

•

Product Catalog: section for working with products in the program database (adding, import,
change of parameters of products, etc.)

For a complete overview of the program interface, see Interface Overview
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Printing Labels

You can print labels directly from the program or from another program / website using the API. For how
to use the API see the Integration Guide.
Next, we will describe how to print labels directly from the program.
Two typical options for printing labels:
1. Using an external data source, such as an Excel file or a database
2. Using the product catalog of the program - a built-in database in which you can store information
about all your products
Go to Label Printing

Add the products for which labels will be printed in the Print Data

You can add products to the list in the following ways:
1. Through import if you are using an external data source such as an Excel file or database.
To add items via import, click the
section.

Import button. To import data, see the Importing Data

2. From the product catalog. To add products from the catalog, click on the button:
azurelabel.com
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Add from Catalog. In the product catalog window that opens, select the desired

•

products / product groups and click the button
•

Add from catalog by barcode. Scan barcodes and products found by these barcodes will
be added to the list.

3. Manually. For manual addition, click the button
, an empty string will be added to the list, then
fill in the required parameters (product name, price, etc.)
4. Adding rows by scanning barcodes or entering them manually. The added rows will contain the
scanned barcode in the Barcode field. Open the context menu of the list of products with the right
mouse button and select the item Add row with a barcode
After adding products to the list, mark the necessary products with the checkboxes on the left side of the
table. You can also set the number of labels for each product in the Number of labels column and change
the product parameters, for example, price.

Choose a template to use when printing labels

If the template you need is not in the list, create a new one or modify the existing one. How to do this is
described in the Creating a label template section.
Press the Print button
to print labels immediately, the Preview and Print button
labels before printing and print settings:

to preview the

To save labels in a PDF, Excel file or as PNG images in the print settings, select the appropriate printer
built into the program:
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You can save print data using the Save button
restored.

3.1

. When you later open the program, print data will be

Printing bundles of products

To print bundles of products, label templates are used that can display items from the bundle. For
example, the "Bundle" template from the standard delivery.

3.1.1

Adding ready bundles of products from the product catalog

Click the Add Products from Catalog button and add ready bundles of products.

3.1.2
Data

Create bundles of products on the fly directly in the Print

1. Select the products you want to put in the bundle

2. Press the right mouse button and select the menu item Create a bundle of products
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3. Choose an option for the main product in the bundle Use current product from selected
products

4. This will result in a bundle of products where the main product is located first and is indicated by
a larger bundle icon

than the rest

To unlink products with bundle:
1. Select any product from the bundle or all
2. Press the right mouse button and select the menu item Unlink products with bundle
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Importing Data

The program allows you to import data from various types of sources.
Data sources are described in the External Data Sources catalog. You can add or change sources using
this catalog. You can go to the External Data Sources catalog through Menu > Catalogs > External Data
Sources.
When importing, the settings of the selected data source are used.

4.1

Normal import (step by step)

In the Label Printing section, Product Catalog section or in any catalog, click the
data import window will open.

Import button. The

Importing data consists of 2 steps:
1. Reading data from a source into the temporary table
2. Adding data from the temporary table to the:
•

Print Data, if import was opened in the Label Printing section

•

Product Catalog, if import was opened in the Product Catalog section

•

Catalog if import was opened in any catalog

4.1.1
table

Step 1 - Reading data from the source into the temporary

Go to the tab 1 Step - Read Data from Source.
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Select the data source. To do this, click on the Data Source field:

The external data source selection window opens:
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Select the data source and click the button.

Then click on

Read Data from Source

If the source is a file and a specific file is not specified in the import settings, a file selection window will
open.

4.1.2

Step 2 - Add data from the temporary table to the Print Data

Go to the tab 2 Step - Import Data (after reading the data, this tab will be opened automatically).
The Data for Import table is the temporary table containing the data read from the source.
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Determine from which row for what data are located that will be imported, and set the first and last lines
of this range:

Bind columns with data fields. To do this, click on the settings icon
in the column header, a window
for selecting the data field that will be bound with this column will open:
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Select the data field to be bound with this column and click OK.
For columns that do not participate in the import, click Don't import this column button when selecting
the data field.
If you have not found a data field that suits you, you can add your own data field (available when
importing into the Print Data):

If you need to set the number of labels for each product (default 1) from your data, then bind the column
containing the number of labels to the data field Number of labels to print:
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Import by clicking the

Import Data button.

The data from the temporary table will be added to the Print Data, Product Catalog or catalog, depending
on where the Import button was clicked.

4.1.3

Refresh data

If the import was made in the Print Data, then the program remembers the parameters of this import and
then you can repeat the import with one click of the Refresh data button

This is useful if you have a single import source, such as an Excel file, and when you change it, you can
quickly load the changed data with a single click of this button.

4.2

One-Click Import

This feature allows you to automatically import data at the click of a Import button.

4.2.1

Preconfiguration

Make the necessary data source settings.
To do this, open catalog External Data Sources via Menu > Catalogs > External Data Sources, select
the desired data source and click Edit
On the Data Read and Data Import tabs, specify all possible settings.
Example settings for importing from an Excel file, in which there is a row with the headings (names) of
the columns. The row with headers is the first in the table, the rest of the rows are data.
Set the file path:
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Set the headers row number and the first data row number:

Bind the data fields to the columns in the file according to the names of the headers in the first row:

4.2.2

Import

Click the button
to the right of the Import button and select the Select a data source for One-click
import item in the menu:

Then сlick button

again and select the One-Click Import option from the menu:

This is a one-time setup that allows you to import automatically without opening the import window.
Next, import by clicking on the Import button.
azurelabel.com
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4.3

Import Settings

To change import settings, click the

Import Settings button or open catalog External Data Sources

via Menu > Catalogs > External Data Sources, select the desired data source and click Edit
The data source settings window will open. Settings are grouped into several tabs.

4.3.1

Data Read > Connection tab

Here you can configure the connection to the data source. The contents of the tab may vary depending on
the type of source.
Purpose of settings:
•

File Path or Database Path: path to the data file. If left blank, the file selection dialog will be
displayed

•

SQL Query: to select certain data from a database

•

User name, Password: for authorization in the database

•

Connection String: to connect to an ODBC source

•

Authorization Token: for authorization in EposNow

4.3.2

Data Read > Reading tab

Here you can configure data reading options. The contents of the tab may vary depending on the type of
source.
Purpose of settings:
•

Headers Row: the number of the row in which the headers are located. 0 - no headers

•

First row with data: row number at which the data begins. 0 - automatic detection

•

Sheet number: the sheet number of the spreadsheet. 0 - a sheet selection window will be
displayed if there are several sheets in the spreadsheet

•

File Encoding: text encoding in the data file

•

Field Delimiter: when reading from a source of type CSV

•

Text Delimiter: when reading from a source with type CSV

•

Data Read Actions:
◦ Bind data fields to columns by keywords: if the flag is set, then data fields will be
automatically bound to columns of the imported data by coincidence with the keywords.
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Keywords are defined on the Data fields tab. Ignored if a direct binding to columns is
specified on the Data fields tab
◦ Determine the range of rows: if the flag is set, the range of imported rows will be determined
automatically, taking into account the setting First row with data
◦ Only on first reading in the session: if the flag is set, then the two previous settings will
work only at the first reading after starting the program

4.3.3

Data fields tab

On this tab, you can bind the data fields used in the program to the columns / fields / entities of the
imported data and set other settings related to the data fields.

4.3.3.1

Relationship with columns / fields of source tab

Purpose of settings for data field:
•

Bind with column:
◦ By number: column number (counting from 1) that is bound with the data field. You can
specify multiple columns, separating them with a space. If you specify multiple columns, the
values from them will be combined using the Value combiner string setting
◦ By header: the source table header or the name of the entity / source field with which the data
field is bound. You can specify several (maximum 3). When specifying multiple headers, the
values from the source fields will be concatenated using the Value combiner string setting

•

Keywords: used if the Bind data fields to columns by keywords flag is set on the Data Read tab
and the data fields are not bound to columns via column numbers or headers. When reading data,
the data field will be automatically bound to the column according to the first partial match with
one of the keywords / phrases. Words / phrases are placed in separate lines.

4.3.3.2

Settings of import / print from source tab

Purpose of settings for data field:
•

Value combiner string: if the data field is bound with several columns, then the values of these
columns will be combined into one line using this line between them.

•

Separating Symbols: column can contain several values separated by any of symbols indicated
here. Separating symbol can be used when enumerating bar codes, Transparency codes, set
contents, goods folders (paths)

•

Column Color: in a temporary table with data in the import window

•

Formula to get value: a formula to change the value in the data field. If left blank, the value of
the data field will be imported unchanged

•

This is an URL or path to a file / folder: if the flag is set, then this data field will be considered
as containing the URL or the path to the file. If the data field contains "https:", "http:" or "ftp:",
then this is the URL, otherwise the path to the file. If this is the path to the file and it is relative,
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then the path is converted to absolute on import (the path to the source file is used as the base
path). If this is the path to the file and it contains only the file name, then the path is converted to
full on import (the path to the source file is used as the base path).
Trim strings: if checked, the blank space (spaces and non-printable characters) will be removed from all
imported string data from the beginning and the end

4.3.4

Data Import > Import settings for the catalog "Products" tab

Here you can set specific import settings for the product catalog.

•

Import to folder: you can select the folder in which the products will be imported. If the folder is
not selected, the products will be placed in the root of the product catalog
◦ Use the current folder at the time of import: if the checkbox is set, The current folder of the
catalog at the moment of pressing the Import button will be used as the folder for import
◦ Search for existing products only in this folder: if the checkbox is set, the search for the
products will be carried out only within the folder for import.
If the checkbox is not set, the product search will be performed in the entire catalog.
Ignored if the rule for updating / adding products Always Add

•

Ignore imported product folders: when the checkbox is set, all products will be placed in the
import folder, if it is selected, or at the root of the product catalog. The presence of folders in the
Folder column of the Data for import table is ignored

•

Rule for updating/adding products: the rule allows you to configure the logic for adding and /
or updating the products:
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◦ Update and Add New: will search for existing products by key data fields specified in the Set
of data fields to search for a product (record). If the products are found, they will be updated
parameters that are not key, otherwise the products will be added
◦ Always Add: products will be added always (no search for existing products will be made)
◦ Only Update: will search for existing products by key data fields specified in the Set of data
fields to search for a product (record). If the products are found, they will update the
parameters that are not key
◦ Only Add New: will search for existing products by key data fields specified in the Set of data
fields to search for a product (record). If no items are found, they will be added.
Search of the products is made in the whole catalog, if the Search for existing products only in
this folder checkbox is not set. If the checkbox is set, the search for the products will be
carried out within the folder for import.
Ignored if the rule for updating / adding products Always Add
•

Clear catalog before import: if the checkbox is set, then the product catalog will be completely
cleared before importing products. Attention! This operation is irreversible

•

Add products to the Print Data: if the checkbox is set, then in addition to adding products to the
catalog, these products will be added to the Print Data in the Label Printing section
◦ Clear Print Data: if the checkbox is set, then before the addition of products, the Print Data
of the Label Printing section will be cleared.
Ignored if the Add products to the Print Data checkbox is not set
◦ Rule for Add: the rule allows you to configure the logic for adding products to the Print Data
of the Label Printing section:
▪ Add all: all imported items will be added
▪ Add new only: only those imported products will be added that were not in the product
catalog (new products)
▪ Add updated only: only those imported products that already existed in the product
catalog will be added

•

Set of data fields to search for a product (record): in the process of importing each line, the
product is searched for in the catalog to determine whether there is such a product or not.
If there is such a product, then it is updated with new data, if there is no such product, then it is
added. You can set another rule for updating/adding products.
The search for an item is performed by a set of data fields. If some data fields from the set are not
imported or their values in some import line are empty (missing), then the remaining data fields
are used to search for an item.
Ignored if the Rule for updating/adding products is Always Add.
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4.3.5

Data Import > Settings for Import to Print Data tab

Here you can set specific import settings for the Print Data.

•

Clear Print Data: if the checkbox is set, then before the addition of products, the Print Data of
the Label Printing section will be cleared

•

Get missing data from the product catalog: In the process of importing each row, a product is
searched in the product catalog.
If the product is found, then the missing data will be taken from the product data.
The search for the product is based on a set of data fields. If some data fields from the set are not
imported or their values in some import line are empty (missing), then the remaining data fields
are used to search for the product

4.3.6

Data Import > Filtering rows on import tab

To filter imported rows, set a condition by clicking the Set formula button. The condition will be checked
on each imported row. The row will be imported if the condition statement is true or the formula returns 1
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Label templates

A template is a sample of a label, in which real data such as the name of the product, price, code, date,
SKU, barcode, etc. are inserted at printing.

5.1

Creating a label template

If you plan to print labels using data from your data source, such as an Excel file, it is best to import
this data before or during template creation for easy template creation.
To import your data, go to the Label Printing section and click the Import button. You can learn
more about import in the Importing Data section.
In any case, if you want the template to display real data, you need to add your data in any way in
the Label Printing section.

Go to Label Designer

Click on the New button

and give the template a name.
Set the dimensions you want

Add elements to the template that will display information. You can use different ways to do this:
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1. Use the toolbar

2. Drag and drop the required fields directly onto the template

3. Drag and drop the required test data column headings directly onto the template

To see all available columns, click the Table Settings button and select the required columns
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After adding elements to the template, you can test print the label by clicking the button
to the Label Printing section.

5.1.1

or go

Example of creating a label template

In this template there are 5 elements that will print different information when printing.
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1. Name of the product
2. QR code that contains a link to the site "http://azurelabel.com"
3. USD currency symbol
4. Price of the product
5. Barcode of the product

5.1.1.1

Step-by-step creation of this template

1. Create a new template
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2. Set the dimensions

and click OK.
3. To display the product name, select the Text tool

4. Click the left mouse button anywhere in the template. A dialog will appear to select the data that
the element will display
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Set the Data field or formula flag, select Name and click Select.
5. Set the desired position and size of the area to display product name

6. Set automatic text size with the type of Fit

7. To display the product price, select the Text tool

8. Click the left mouse button anywhere in the template. A dialog will appear to select the data that
the element will display
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Set the Data field or formula flag, select Price and click Select.
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9. Set the desired position and size of the area to display product price

10. Set automatic text size with the type of Fit

11. To display the euro currency symbol, select the Currency Symbol tool

12. Click the left mouse button anywhere in the template
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13. Select the USD currency symbol

14. Set the desired position and size of the currency symbol

15. To display the barcode, select the Barcode tool

16. Click the left mouse button anywhere in the template
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17. Select the type of barcode

and click Select
18. Set the desired position and size of the barcode

19. To display the QR code, select the 2D Barcode tool

20. Click the left mouse button anywhere in the template
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21. Select the type of barcode

22. Go to the Data source for barcode tab
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23. Set the Text flag, enter the web site address and click Select

24. Set the desired position and size of the QR code
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25. Save changes to the template

5.1.2

Example of creating a label template for a product bundle

You can create a label template that displays data for several related products (bundle) in two ways:
1. By placing elements that display data, as in a regular label for a single product, but specifying the
data sources for these elements: the main product in the bundle, the first, the second, etc.
This can be done in the properties of elements:

In this example, the element will display the name of the first (non-main) item in the bundle.
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An example of such a template, which displays data for two products:

2. Using a special mechanism for automatic placement of products data from the bundle

5.1.2.1

Special mechanism for automatic placement of products data from the bundle

This mechanism implements the following template structure:
•

Header
The data of the main product in the bundle and other data

•

Repeating region
◦ The data of the product 1 in the bundle and other data
◦ The data of the product 2 in the bundle and other data
◦ ...
◦ The data of the product N in the bundle and other data

•

Footer
The data of the main product in the bundle and other data. Displays immediately after the
repeating region
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In this example 1 - header, 2 - repeating region (in edit mode repeatings are not displaying), 3 - footer.
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This template in the preview:

You can see that the repeating area appears 3 times for all three non-main items in the bundle. Data on the
main product of the bundle is displayed in the label header (in this case, only the name).

Implementation of the header
Place elements in the usual way.

Implementation of the repeating region
Go to template properties, go to the Layers tab, then to the Regions of Layer tab:
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Select data source Bundle Contents. You can also configure additional parameters. Click OK.
Place the elements in the template in the usual way, given that this entire group of elements will be
displayed several times, so you need to leave room for repetitions.
Go to the properties of each element on the Size and Position tab and set the layer region to Repeating:
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Implementation of the footer
Go to template properties, go to the Layers tab, then to the Regions of Layer tab:
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Set the desired offset from the repeating region. Click OK.
Place the elements in the template in the usual way, bearing in mind that this entire group of elements will
appear immediately after the repeating region.
Go to the properties of each element on the Size and Position tab and set the layer region to Footer:
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You can see the implementation of this method in the Bundle template.

5.2

Modifying the label template

If you plan to print labels using data from your data source, such as an Excel file, it is best to import
this data before or during template creation for easy template creation.
To import your data, go to the Label Printing section and click the Import button. You can learn
more about import in the Importing Data section.
In any case, if you want the template to display real data, you need to add your data in any way in
the Label Printing section.

Go to the Label Designer section
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5.2.1

Changing Label Sizes and Other Options

1. Click the Template Properties button or on the field with the template description:

2. Set the dimensions you want:

3. Set other parameters if necessary

5.3

Template structure

5.3.1

Elements

Templates consist of such elements as Text, Rectangle, Circle, Barcode (1D and 2D), Image, Icon,
Currency Symbol etc.
Each element can display:
•

static data - text

•

variable data - data from data fields (e.g. product parameters, counter values, etc.)

A formula is used to display variable data.
Also, each element can display a background image or an image of the product (except for Barcode
element).
Each element can be set visibility by certain conditions through the formula.
All elements can be placed in the template anywhere and rotated at any angle.

5.3.2

Layers

Elements in the template are grouped into nine layers. Each layer can be given visibility by certain
conditions through the formula.
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5.3.3

Formulas

Formulas are used to display data from data fields, as well as to set the visibility of elements or layers.
To insert and edit formulas in the application, there is a formula designer, which is described in the
Formula Designer section.
Formulas look like:
[Initial value] [Function 1] [Function 2] ... [Function N]
The initial value can be any valid data type. It may be absent explicitly, then it will be considered an
empty string.

5.3.3.1

Types of data in formulas

•

Text: enclosed in double quotes.
Example: "This is a text"

•

Number:
Example: 123.4

•

Date / Time: enclosed in single quotes.
Format:
◦ YYYY-MM-DDThh:mm:ss
◦ YYYY-MM-DD hh:mm:ss
◦ YYYY-MM-DD
, where YYYY - year 4 digits, MM - month 2 digits, DD - day 2 digits, hh - hour 2 digits, mm minutes 2 digits, ss - seconds 2 digits.
Examples: '2020-09-12T03:41:00', '2020-09-12 03:41:00', '2020-09-12'.

•

Data field: enclosed in square brackets. For standard fields, the names for use in formulas are
used, for other data fields, the name for use in formulas is the same as the name of the field.
Examples:
◦ [ProductPrice] - here the data field Price is represented in the formula named ProductPrice
◦ [My parameter] - here the custom data field My Parameter is represented in the formula
under the same name My Parameter
◦ [CurrentDate] - here the virtual data field Current date, which contains the current date, is
represented in a formula named CurrentDate

5.3.3.2

Functions in formulas

Functions perform various actions - arithmetic operations, processing of strings and dates, formatting, etc.
The functions in the formula are executed sequentially from left to right. The first function in the formula
handles the initial value of the formula, the second value obtained from the first, the third value obtained
from the second, and so on.
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Functions can be nested and include other functions.
Examples of formulas with functions:
•

100 AddPercent( 5 )
In this example, the function of adding percentages to numbers is used. The function adds 5
percent to the number 100, and displays the resulting value of 105.

•

[ProductPrice] AddPercent( 12.3 ) Round( "0.5" )
In this example, the functions of adding percentages to numbers and rounding are used. The
function adds 12.3 percent to the price of the product (the data field Price is represented in the
formula under the name ProductPrice, which is used in the formulas), then rounds the resulting
value to an accuracy of 0.5, and displays the resulting value.

5.3.3.3

Data fields and counters in formulas

In formulas, you can use either the standard data fields and counters, which will be listed below, or your
own data fields.
When adding new columns, new data fields appear in the product catalog, corresponding to these
columns.
When printing with external data, the names of the data fields in the template must match the names of
the data fields in the transmitted data.
Standard data fields, including virtual ones (counters, current date, etc.):
Data field name for
formulas

Data
type

ProductName
ProductSKU
ProductCode
ProductExpirationDate
ProductDescription
ProductCharacteristic
ProductPLU
ProductDiscount
ProductWeight
ProductPrice
ProductStock
ProductColor
ProductSize
ProductWidth
ProductHeight
ProductLength
ProductTax
ProductMPN
ProductISBN
ProductPrice2...

String
String
String
String
String
String
Number
Number
Number
Number
Number
String
String
Number
Number
Number
Number
String
String
Number
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Data field name

Notes

Name of product
Product SKU
Product code
Shelf life of product
Product description
Product characteristics
PLU of the product
Discount for product
Product weight
Product price
Remains of the product
Color of the product
Size of the product
Width
Height
Length
Tax
MPN
ISBN
Product price 2...9
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ProductPrice9
ProductPriceOld
ProductParam1...
ProductParam9
Barcode

Number
String
String

BarcodeType

Number

BarcodeIsMain

Boolean

UniqueCode

String

UnitName
CountryName
CountryISO
Brand
CategoryName
DocName
DocDate
DocNo
DocNote
CompanyName
CompanyCode
StoreName
StoreCode
SupplierName
SupplierCode
ManufacturerName
ManufacturerCode
PartnerName
PartnerCode
PartnerPhones
PartnerBankAccount
PartnerBankName
PartnerBankCode
PartnerBankCorresponden
tAccount
CurrentDate
LabelCount
LabelCounter
LabelCounterDesc
ProductLabelCount
ProductLabelCounter

String
String
String
String
String
String
String
String
String
String
String
String
String
String
String
String
String
String
String
String
String
String
String
String
String
Number
Number
Number
Number
Number

ProductLabelCounterDesc Number
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Old price of product
Additional product parameter
1...9
Product barcode
ID of type of barcode. The ID
can be seen in the list of barcode
types on the Barcode tab in the
properties of the template
element
This is the main product
barcode.
Product Amazon Transparency
code
Unit of measurement
Country name
ISO of the country
Brand name
Product category name
Name of the document
Date of the document
Document number
Document note
Name of company
TIN of company
Warehouse name
Warehouse code
Supplier name
Supplier code
Manufacturer name
Manufacturer code
Name of partner
Partner TIN
Phones of the partner
Bank account of the partner
Name of the partner bank
TIN of partner bank
Correspondent account of the
partner
Current date
Number of all labels
Counter of all labels
Decreasing counter of all labels
Number of product labels
Counter of product labels
Decreasing counter of product
labels
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ProductCount
ProductCounter

Number
Number

ProductCounterDesc

Number

PageLabelCount
PageLabelCounter

Number
Number

PageLabelCounterDesc

Number

TemplateID
TemplateName
TemplateCaption

Number
String
String

TemplateCreateDateTime

String

UserName
ExtDataName

String
String

ExtDataConnData

String

IsFavorite
LastChangeDateTime

Boolean
String

Number of all products
Counter of all products
Decreasing counter of all
products
Number of labels on the page
Counter of labels on the page
Decreasing counter of labels on
the page
Template ID
Template name
Template description
Date / time the template was
created
User name
Name of external data
Connection string with external
data
My favorites
Date / time of last change

Group

String

-

ProductImage

String

-

BundleID

Number

-

BundleIndexNumber

Number

Sequence number in the bundle

UseAsBundleItemOnly

Boolean

-
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The name of the product
folder or the path to the
product folder in the catalog.
Used only when importing /
printing from external data.
Product image.
Used only when importing /
printing from external data.
The identifier of the bundle.
Items with the same identifier
are considered a bundle.
Used only when importing /
printing from external data
and in Print Data.
0 - the main product in the
bundle, 1,2,3 ... - other
products in the bundle.
Used only when importing /
printing from external data
and in Print Data.
Use only as part of the
bundle. If the value is True,
then the product is not
printed on its own, but only
as part of the bundle.
Used only when importing /
printing from external data
and in Print Data.
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6

Print Settings

Any changes to the print settings are stored in the program database.
The print settings are saved with the Template-Printer binding, i.e. for each template there will be
different settings for different printers. In multi-user mode, print settings are saved with the UserTemplate-Printer binding, i.e. for each user their print settings.
•

Actions menu:

◦ Apply current print settings to other users: allows you to apply the settings for another
user(s) in multi-user mode. Clicking will open the window of selecting users for which you
want to apply these settings.
◦ Apply current print settings to another printer: allows you to apply the settings for another
printer / saving to a file. Clicking will open the window of selecting printer for which you
want to apply these settings.
◦ Delete current print settings : removes the current settings from the program database.
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6.1

General tab

•

Template: the label template whose settings you see.

•

Use layout of labels from template properties: if the checkbox is set, then the sizes and location
of labels from the Print options tab of the template properties will be used.

•

Choose pre designed layout of labels: when you click on the button, the window for selecting the
layout of the labels will open:

Expand the folder of the desired manufacturer and select the desired layout:

azurelabel.com

49

Press the button
•

Printer: the printer that will print the labels. This can be a local printer, network printer or any, for
example, local printer from another computer.

•

Printer Properties: pressing the button displays the printer settings dialog.

6.2

Page tab

Size
Here you can select from the list or manually set the size of the page on which the labels will be printed.
Orientation
You can select the orientation of the page.
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6.3

Labels Layout tab

Labels Layout
Here you can set the number of labels horizontally and vertically, the vertical and horizontal gaps between
the labels, the direction in which the labels are printed.
•

Auto placement: if the checkbox is set, then the number of labels horizontally and vertically will
be determined automatically, based on the size of the label, the gaps between the labels and the
margins.

Margins
Here you can set the margins to the left, right, top and bottom.
•

Auto detect margins: if the checkbox is set, the minimum margins from the printer settings will
be set.
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6.4

Label Size tab

Label Size
Here you can specify the dimensions and radii of the label.
•

Keep aspect ratio when resizing: if the checkbox is set, if the width is manually changed, the
height will be changed proportionally, and vice versa.

•

Fit to page: if the checkbox is set the size of the label when printing will be set equal to the size
of the page, taking into account the margins.
Only visible if one label is printing on the page (for example, when printing labels on a label
printer).

•

Set from template properties button: when you click on the button, the dimensions and radii of
the labels will be taken from the Template properties.

•

Fit to page button: when the button is pressed, the label sizes will be set so that the labels do not
go beyond the boundaries of the page. This takes into account the current number of labels on the
page horizontally, vertically, the gaps between the labels and the margins.

Offset
Sets the offset of all printed labels from the left and top edges of the page.

6.5
•

Options tab
Group pages by store: allows printing labels for each store on a separate page

When saving labels to PDF, Excel, or an image file:
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•

Set formula: allows you to specify a file name when saving labels to a file. The file name can be
static or dynamic, such as the current date and time. If the formula is not specified, then the save
to file dialog with an automatically generated file name will be shown. If there is no path in the
file name, then the dialog for saving to file with the name obtained from the formula will be
shown

•

DPI: resolution of the saved images

When saving labels to separate image files:

•

Set formula: allows you to specify a file name when saving labels to files. The file name can be
static or dynamic, such as the current date and time. If the formula is not specified, the product
name will be used and the folder selection dialog will be displayed. If there is no path for the file
name, the folder selection dialog will be shown

•

DPI: resolution of the saved images

•

Format: format of saved images
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7

Table Settings

The window is intended for customizing the appearance of tables. Also, this window, opened from the
product catalog, allows you to add new columns to the product catalog.
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•

Add Column: when pressed, the window for adding a new column will open:

◦ Name: the name of the new column.
◦ Type: data type in a new column:

◦ Size (in symbols): the maximum size of the string that will be stored in the new column. Only
for a string data type.
◦ Name of the data field to use in formulas: the name of a data field that can be used in
formulas, such as label templates, to display that column's data on a label.
Data field Properties
•

Column Width: column width in points.

•

Name for use in formulas: the name of a data field that can be used in formulas, such as label
templates, to display that column's data on a label.

•

Display format: allows you to specify in what form the numerical data will be displayed (number
of decimal places, currency display, etc.).
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8

Program settings

8.1

Database section

•

Single User Mode: if the flag is set, then the program runs in single-user mode.

•

Multi User Mode: if the flag is set, then the program runs in multiuser (client-server) mode.

8.1.1
Single-user mode of operation (license Free, Lite,
Professional or trial mode)

In this mode, the program works with a local database located on this computer or external media
connected to this computer.
Database
The path to the database file.
•

Default: when you click on a link, the path is set to the default value.
: when you click on the button, the dialog for selecting the database file opens.

•

8.1.2

Multi-user mode (Corporate license or trial mode)

In this mode, the program runs in client-server mode. In this case:
•

The database is located on one server computer. The database access service and the licensing
service will be launched on this computer. This computer must be turned on for the client software
to work.

•

Client programs connect to the database and licensing service on the server computer through a
computer network or through remote desktop (RDP).
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•

This is a server + workplace: if the flag is set, then this computer is a server computer and the
database is located on this computer. The database access service and the licensing service will be
launched on this computer.
The computer server can also be used as a workplace.

•

This is a client (workplace): if the flag is set, then this program will be a client and connect to the
server computer

8.1.2.1

Server (the computer on which the database is located)

Database
The path to the database file.
•
•

Default: when you click on a link, the path is set to the default value.
: when you click on the button, the dialog for selecting the database file opens.

Address for connecting clients (workplaces)
Here you can copy the server address for use in client program settings.
For the client-server version to work, you must open ports 42101 and 42102 for incoming connections.
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8.1.2.2

Client (the program that connects to the server)

Server address
Here it is necessary to set the network interface address on the server computer to which this client
program will connect. This address can be copied in the server computer settings in the Address for
connecting clients (workplaces) area

For the client-server version to work, you must open ports 42101 and 42102 for outgoing connections.

8.2

Interface section

•

Unit of Length: the unit specified here acts globally in the entire program.

•

Save Print Data: if the checkbox is set, then print data will be stored in the database and restored
when the program starts.

•

Use [Tab] in the tables: if the flag is set, then in the tables the transition to the next column is also
possible via the [Tab] key, return to the column back by [Shift] + [Tab]

•

Theme: you can choose the theme of the program.
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8.3

•

Print section

Use date from the Print Data > General Data as current date: if the checkbox is set, the date
from the General Data tab of the Print Data will be transferred to the [CurrentDate] variable
when printing labels, instead of a current date.

Behavior when adding products to the Print Data
Here you can specify how the products will be added to the Print Data, if the products have barcodes or
Transparency codes.
•

Add a product with one (main) barcode: one product will be added with the main or last
barcode by the date of adding. Transparency code will not be filled.

•

Add as many product copies as many barcodes. Each copy with its own barcode: so many
copies of this product will be added, how many barcodes this product has. Each copy of the
product will have a different barcode.

•

Add as many product copies as many Transparency codes. Each copy with its own code: as
many copies of this product will be added as this product has Transparency codes. Each copy of
the product will have its own Transparency code.

•

Add as many product copies as many not yet printed Transparency codes. Each copy with its
own code: as many copies of this product will be added as this product has not yet printed
Transparency codes. Each copy of the product will have its own Transparency code. (default)
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8.4

Catalogs section

Here for each catalog, you can select the default value that will be used for new products in the product
catalog. For example, if you set the Units catalog to the default value of "ea", when you add a new item to
the catalog, its unit will automatically be set to "ea".

8.5

Export section

In this section, you can set the settings that will be used when exporting data from the program.

8.6

Other section
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8.7

API section
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9

Licenses

9.1

Types of licenses

9.1.1

Single-user license (Free, Lite, Pro)

A single user license allows you to install and run AzureLabel on a single computer. The license is
activated on the same computer.
Maximum number of printers used in any four hour period: 2.

9.1.2

Multi-user (floating) license (Corporate or Trial)

A multi-user (floating) license allows you to run an unlimited number of AzureLabel instances on an
unlimited number of computers, if these computers are on the same local network with the host computer
or are connected via Remote Desktop (RDP) to the host computer.
Maximum number of printers used in any four-hour period: 3..255 - the number is determined at the time
of purchasing the Corporate license. Unlimited for trial mode.
The license is activated on the main computer. User computers do not require license activation.

9.2

How AzureLabel licensing works

The program keeps track of the number of printers in use, which you can see through Menu > Tools >
Licenses, Used printers.
If no one uses the printer for 4 hours, the program automatically removes this printer from the list of used
ones. This frees up license space for another printer.
The program identifies printers using a combination of:
•

Printer name.

•

The first folder in the path (for network paths) or drive letter (for local and network drives). Used
only when saving to a file.

Example of identifiers for printers: "XYZPrinter 123", "\\server\ZYXPrinter 321".
Example of identifiers to save to a file: "Saving to PDF > C:", "Saving to PDF > \\print folder".

9.3

License activation

Go to Menu > Help > License Activation.
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The window of the license activation wizard will open.

Select the activation type Activation and click Next.
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Insert your license key in the appropriate field and click Next.
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Select the activation method and click Next.

9.3.1

Activation via the Internet

If this option was selected, the program will activate via the Internet and will go to the message of
successful activation. After the activation wizard's window is closed, the program restarts to accept the
changes.

9.3.2

Activation through filling out the form on the program website

If this option was selected, then the page with the instruction will be displayed on how to activate on the
program's website:

azurelabel.com

65

Follow the instructions and click Next.
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Paste the activation code received on the site and click Next.
The program will activate and will go to the message of successful activation. After the activation
wizard's window is closed, the program restarts to accept the changes.

9.4

License deactivation

You can deactivate a license to transfer it to another computer up to two times without contacting support.
Deactivation for the third time and more is carried out through an appeal in support of the program.
Go to Menu > Help > License Activation.
The window of the license activation activation wizard will open, which will be used to deactivate the
license.
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Select the activation type Deactivation and click Next.
The program will deactivate via the Internet and will restart to accept the changes.
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10 Installing the program on your
computer
System requirements
32-bit or 64-bit Windows operating system: Windows 10 / Windows 8 (8.1) / Windows 7 / Windows Vista
/ Windows Server 2016 / Windows Server 2012 / Windows Server 2008

10.1

Downloading the installation file

Go to the official site of the application azurelabel.com in the Download section and click on the
Download AzureLabel button

If there is a question

click on Save File.
After downloading the installation file AzureLabel10_setup.exe will start and the process of installing
the application on the computer will begin.
If the installation does not start, then in the browser where the installation file (Chrome, Firefox, Edge,
etc.) was downloaded, press [Ctrl] + [J], find the file AzureLabel10_setup.exe and run it.

10.2

Installation process

After starting the installation file, the security window will open:
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Click on Yes.

Select installation language from the drop-down list and click OK.
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Choose an installation option:
•

Easy Install (recommended)

•

Custom Install

•

Portable
To enable this option, select Custom Install and set the Portable checkbox

Click on Next.

10.2.1

Easy Install

A simple installation is designed to install a program that will work:
•

In single-user mode of operation (license Free, Lite, Professional or trial mode).

•

In multi-user mode (Corporate license or trial mode) as a server.
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Accept the terms of the license agreement and click on Next.

Select the modules to install and click Install.
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10.2.2

Custom Install

Advanced installation adds additional options to a simple installation:
•

Select the folder to place the program.

•

Select the type of program installation for multi-user mode (Corporate license or trial mode):
Server or Client.

•

Configure the creation of a folder and shortcut in the Start menu, and create a shortcut on the
desktop.

•

Is designed to install a program for multi-user mode (Corporate license or trial mode).

10.2.3

Portable

Portable installation is designed to install a program that will work in single-user mode (license Free,
Lite, Professional or trial mode) without installing it on the computer, simply unpacking everything
necessary for the program to work in one user-selectable directory. This directory can be located either on
the computer's disk, or on a portable medium, in which case you can carry the program and all the data
with you.
Important Features
1. The installation path must contain only latin characters
2. The disk letter must be the same when used on multiple computers

10.2.4 Features of the installation for multi-user mode (Corporate
license or trial mode)
10.2.4.1

Installing the program: Server

Select installation option Easy Install.
After installing the program, make the settings in accordance with the Server (the computer on which the
database is located) section.

10.2.4.2

Installing the program: Client

Select installation option Custom Install.
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In the Settings of work with database window, clear the checkbox.
After installing the program, make the settings in accordance with the Client (the computer that connects
to the server) section.

10.3

Update

An update we will call a program update if the major number in the version does not change. For
example, from version 10.11 to 10.12, the number 10 is the major number and it does not change. If the
major number changes, then this is an upgrade of the program, for example, from version 8 to version 10.
You can read how to upgrade in the next Migration from previous versions section.

10.3.1

If the program is operating normally

Run the program and wait about 5 seconds to check for updates. If the program detects an update, then it
will download it and then offer to install it - agree. This will only work if the Check for Application
Updates in the Other section is setted in the program settings.
To manually check for updates, go to Menu > Help > Check for Updates.

10.3.2

If the trial period has ended

Go to Menu > Help > Check for Updates.
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11 Migration from previous
versions
11.1

Procedure for migrating to a new version

1. Install new version and transfer data from the old version (automatically during installation or
manually later). Data transfer is described below.
2. Deactivate the old version
3. Activate the new version

11.2

Transfer all data from version 5 and newer

11.2.1

Automatic data transfer during program installation

If the previous version of the program is found during the program installation, then it will be suggested
to use the data from the previous version of the program:
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If you want to use data from the previous version of the program, select Copy settings and database...
and click Next. In this case, the data from the previous version of the program will be copied to the
installed version of the program.

11.2.2

Manual transfer of all data

Close the latest version of the program if it is running.
1. Change to the directory with the data of the previous version "%ProgramData%\PriceLabelX",
where X is the first digit of the old version of the program. For example, "C:\ProgramData\
PriceLabel10". Or, for program versions 5 to 7, this is the "%ProgramData%\PricePrintX"
directory, where X is from 5 to 7.
You can go to the directory with the program data from the program of the previous version via
Menu> Help> Open application data folder
2. Copy the contents of the directory
3. Change to the data directory of the latest version "%ProgramData%\AzureLabel11". For example,
"C:\ProgramData\AzureLabel11".
You can go to the directory with the program data from the program of the previous version via
Menu> Help> Open application data folder
4. Move the entire contents of the directory to a different location (in case the data transfer is
canceled)
5. Paste into the directory the copied contents of the directory from the previous version of the
program

11.3 Manual transfer of templates from version 2 and
newer
1. Export the templates you need from the previous version of the program. You can find out how to
do this by going to the previous version in Menu > Help > User Guide (or Help)
2. Go to Label Designer
3. Click on All Templates

4. Go to Actions > Import Templates

The template selection dialog will open.
5. Select the template files exported from the previous version and click Open
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12 Interface Overview
12.1

Label Printing section

The section is intended for printing labels, price tags, etc.

12.1.1

Label Template

When printing labels, the selected label template will be used. To select a template, click the Choose
button.

If a different template is specified for the product, then this template will be used for printing:

12.1.2

Print Data

Print Data is a list of products for which labels will be printed, as well as data common to all labels.
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12.1.2.1

Product List

This is a table with products and product parameters, such as prices, barcodes, SKUs, discounts, units,
etc.

For each product in the list, you can specify the number of labels to be printed.
The product can be a single item

, the main item in the bundle

, or not main item in the bundle

.

12.1.2.2

Product List Command Panel

The command panel allows you to perform various actions for a product or a group of selected products.

Top buttons:
•

Import: opens a window for importing products or imports products immediately if OneClick Import is enabled
◦

: re-import data using the parameters of the previous import

•

Add products from catalog: opens window for selecting products from the product catalog
and adding selected products to the product list

•

Add products from catalog by barcode: opens barcode input / scan window. After entering /
scanning the barcode, the product is searched in the product catalog and the product found is
added to the product list

Bottom buttons on the left:
•

: setting the value in the current column for the selected rows

•

: copying lines (creating new lines by copying existing ones)

•

: deleting rows

•

: clearing the list

•

: moving higher in the list
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•

: moving lower in the list

•

Search: search by various parameters of products

•

: cancel search

•

: search / add products by barcode

•

: adding a new blank row to the list

•

Set template: setting a label template for selected rows

Bottom buttons on the right:
•

: show only columns used in the template and used in the last import. When the button is
pressed, only those columns will be visible, the values of which are used in labels when printing
or were used in the last import. If templates are attached to products, they are also taken into
account.

•

: show image. When the button is pressed, product images will be displayed, if any

•

: opening the table settings window

12.1.2.3

Product List Context Menu

12.1.2.4

Product image

In this area, the product image is displayed. You can add
image.
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You can add an image using Drag & Drop.

Showing / hiding the image of the products is possible via button

12.1.2.5

Table Settings button

The Table Settings button is used to show the Table Settings window.

12.1.2.6

General Data

These are data that are the same for all printed labels. Information input into this section will be applied to
all labels. For example, this is the name of the organization, the warehouse, the current date, the specified
date, etc.

12.1.2.7

Actions menu

The Actions menu is designed to export a list of products.
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12.2

Label Designer section

Label designer is designed to create new ones or modify existing label template.

12.2.1

Insert / Select toolbar

•

: element selection

•

: inserting the Text element

•

: inserting the Shape element (Rectangle, Line, Rounded rectangle, Circle, Arc, Pie, Star etc.)
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•

: inserting the Barcode element

•

: inserting the 2D Barcode element

•

: inserting the Image element

•

: inserting the Icon/Symbol/Clipart element

•

: inserting the Currency Symbol element

12.2.2

Elements area

The scope contains a list of template elements, with the ability to filter by layer.
In the list of elements, the line consists of the icon of the element type, element ID, data fields displayed
by the element, element formulas.

12.2.3

Data source fields area

The scope contains a list of data source fields.
All imported fields from an external data source, such as an Excel spreadsheet, will be shown here if you
imported into Print Data. If there was no import from an external source to Print Data then all available
fields will be shown here.
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Fields can be dragged onto template elements to have template elements display the data for those fields,
or to empty template space to create new elements that display these field data.

12.2.4

Template editing area

You can change the zoom level by clicking on the scale value, using the slider or the - and + buttons.
To fit the template in the editing area, click
To view it in real size, press
The Printer DPI is used to evaluate the appearance of the template at various printer resolutions. If you
previewed this template, this will set the resolution of your printer.
Also, you can evaluate how the label will look with the limitations of a license in order to determine what
license is right for you. To do this, use the list at the bottom right:

12.2.5

Top panel
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•

Save: saving changes to the template

•

: undo of changes made

•

: redo the changes made

•

Template Properties: opening the Template Properties window

•

Actions: various actions on the template

•

All Templates: opening the catalog with templates to view templates, select a template for
editing

•

New Template: creating a new template

•

Create a copy: creating a new template based on the current one

•

Preview: opening a print preview with test data

•

Training video: watching a training video

•

Order a template: ordering the production of a template on the program website
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12.2.6

Element editing panel

On the panel are often used tools for editing the properties of the element / group of elements tools.
•

Element Properties: opening the Element Properties window to access all properties of the
element

12.2.7

The bottom panel

12.2.7.1

Show real data button

When the button is pressed, the template will display your data from the current line of the Print Data
from the Label Printing section (top menu).
If the button is released or there is no data in the Label Printing section, then service data will be
displayed in the template.
You can change and select your data in the Label Printing section to any, which will help you evaluate the
appearance of the label.
You can also open a preview with your data by clicking on the
the labels.

12.2.7.2

button (top panel) and print

Errors and event log button

When the button is pressed, a log will be displayed, which displays template errors and service messages.
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12.2.8

Template properties

12.2.8.1

Size tab

The tab is intended for setting the dimensions of the label and its rounding radii.
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12.2.8.2

Print options tab

The tab is used to set the layout of labels on the page.
• Automatic layout of labels on the print page: if the checkbox is set, labels will be placed
automatically based on the size of the label and the size of the print page that will be selected in
the print settings.
•

Set parameters for printing on a roll of labels: when you press the button, the horizontal and
vertical counts will be set to 1, the page size will be set to the template size

•

Choose pre designed layout of labels: when you click on the button, the layout window for the
layout of the labels will open:
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Expand the folder of the desired manufacturer and select the desired layout:

Click on the button
Labels Layout
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You can set the number of labels horizontally and vertically, the vertical and horizontal gaps between the
labels, the direction in which the labels are printed.
Page size
You can select the page size from the list or manually set it.
Page orientation
Select the desired page orientation.
Margins
Here you can set margins from the edges of the page.

12.2.8.3

Layers tab

On this tab you can set the visibility of each layer under certain conditions. You can also configure the
output of a repeating region and a footer for each layer.

azurelabel.com

89

Layer Visibility

You can adjust the visibility of the layer, depending on the conditions in the form of a formula. If
visibility conditions are specified for a layer, then they have priority over the visibility conditions for
elements in this layer.

Regions of Layer

On this tab you can configure the output parameters for the repeating area and the footer. Usually in the
label, all data is output to the Static region, but if you need to display repeating information, for example,
all products from a bundle, then the Repeating region is used. After a repeating area, the Footer area can
be displayed, which will be located immediately after the end of the repeating area.
Repeating region
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•

Data Source: here you can select a data source for a repeating region:

•

Direction of Region Output: the area can be displayed from top to bottom or from left to right.

•

Offset: specifies the offset between repetitions.

•

Number of Repetitions: specifies the number of repetitions.

Footer region
•

Offset: sets the offset between the last repeat and the footer.

12.2.8.4

Other tab

On this tab, you can select the type of template. When you select the Printer language script template
type, a field will appear for entering the printer script and formulas for outputting parameters.
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12.2.9

Template element properties

12.2.9.1

Data Source tab

Here you can set the data source for displaying text information within the bounds of this element.
Type
•

Text. To display static text.
You can add a currency symbol to the text with the
Currency symbol button or any symbol
available from the Windows character table with the Character map button.

•

Data field or formula. To display data from data fields (for example, product parameters,
counters, etc.) and text using a formula.
To select the required data field, click on the field below:

To set the format for numbers or dates, click the Customize the display format button.
For advanced configuration, click the
opened.
•

Change formula button, Formula Designer will be

Pascal scripts. Using a script in the Pascal language, which allows you to use all the capabilities
of this language to display data from data fields (for example, product parameters, counters, etc.)
and text.
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Text format
•

Plain text. Text without formatting. Text style is set on the Text Style tab or in the left toolbar of
the Designer

•

Rich Text (RTF). Text containing RTF formatting. Text style is set on the toolbar below

•

HTML. Text containing HTML formatting. Basic text style (font, font size, and font color) is set
on the Text Style tab or in the left toolbar of the Designer

12.2.9.2

Barcode tab

The tab is visible only if the element type is Barcode or 2D Barcode.

•

Type: you can select the desired barcode type from more than 50 types.
If type Auto is selected, the program will analyze the length of the barcode and other parameters,
and automatically determine the appropriate type:
◦ If the barcode contains only numbers: depending on the length of the barcode, UPC E, UPC
A, EAN 8, EAN 13 or CODE 128 will be selected
◦ If the barcode contains not only numbers: if the barcode contains characters that are valid
for CODE 39, CODE 39 will be selected, otherwise CODE 128 will be selected
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•

Show Text: if the checkbox is set, then the barcode will be displayed not only in coded form, but
also in the form of text / numbers:

•

Do Not Show Errors: if the checkbox is set, errors related to the wrong barcode transmitted to
the template will not be displayed. Otherwise, the errors will be displayed as a red rectangle with
the error text:

For some types of barcodes, additional settings will be shown:
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12.2.9.3

Text Style tab

On the tab, you can specify the style of the text displayed by the element: font and its parameters,
paragraph parameters, autosize of the font, etc.
•

Autosize: if the checkbox is set, then the font size will be calculated automatically according to
the rules:
◦ Reduce text at the exit of element dimensions: if the text does not fit into the boundaries of
the element, the font size will be reduced so that the text size fits into the element's size. The
font size can not be less than the specified minimum font size.
◦ Fit the text in element size: the font size will be chosen so that the text size fits into the size
of the element. The font size can not be less than the specified minimum font size and can not
exceed the specified maximum font size.
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12.2.9.4

Border tab

On the tab, you can set the border style, as well as for polygonal elements (rectangle, triangle, etc.)
visibility of the sides.
In addition, you can specify the position of the vertices of the polygon relative to the boundaries of the
element, which allows you to form figures other than the standard ones.

12.2.9.5

Background tab
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Here you can set the fill style.

12.2.9.6

Image tab

Here you can configure the display of the image (background or dynamically acquired).
Dynamic image acquisition
•

Method of getting:
◦ Don't use an image: the image will not be received and, accordingly, displayed at the time of
printing / viewing. A background image will be displayed, if specified.
◦ Use product image: at the time of printing / viewing, the product image will be used, if there
is one, if not, the background image will be displayed, if it is set.
◦ Get by link (URL or file path): at the time of printing / viewing, an image will be received at
the specified link, if there is one, if not, the background image will be displayed, if it is
specified.
To set a link, click the Set formula button

Example formulas:
"http://goods.com/image.jpg" static link formula.
[ProductParam4] the formula will use the link / path from the Parameter 4 data field.
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12.2.9.7

Shape tab

On this tab you can change the element type and specify parameters specific to certain types of elements.
For example, for Rounded Rectangle, this is Rounding and Ratio:
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12.2.9.8

Size and Position tab

Here you can specify the size and position of the element relative to the template, the rotation angle, etc.
•

Fit size to size of displayed text: if the checkbox is set, the boundaries of the element will be set
according to the size of the text displayed by the element.

•

Layer: the number of the layer to which the element belongs.

•

Region of Layer: type of the area of the layer to which the element belongs:

•

Flip: allows you to display the element as reflected:

Constraints
You can set the maximum and minimum sizes of the element for cases when these sizes can change, for
example, when binding to another element or fitting the size to the size of displayed text.
Anchors
You can bind the sides of an element to the sides of other elements, so that when the size of another
element changes, this element follows this change. To bind one element to each other:
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•

choose the side of this element that will be tied (left, right, top, bottom)

•

select the side of the other element to which you want to bind

•

select the ID of another element from the list

•

set the offset between the parties to be tied

12.2.9.9

Visibility tab

Here you can specify the conditions in the form of a formula, under which the element will be visible.
An example of a visibility condition:

In this case, the element will be visible if the value of the data field Parameter 4 is equal to 123.
If the element should not be printed, set the flag Not printable. Then the element will be visible in the
process of editing the template, under the conditions of visibility, but will not be printed.

12.2.10 Formula Designer
The Formula Designer is used to easily create or edit a formula.
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Edit Expression: when you click on the button will open the window:
•

Value Select (described further), if the expression type is an initial value of the formula or a
function argument

•

Function Select (described further), if the expression typ is a function. In this way, the function
can be replaced with another

Customize the display format: when you click the button, a window for setting the format for displaying
numbers and dates will open.
Add Function: when you click on the button will open the window Function Select. Once selected,
the function will be placed at the end of the current formula.
Delete Function: when you click on the button will delete the selected function.
: buttons move the selected function up or down the list within the current formula. The position
of the function in the list determines the moment of its execution (the higher, the earlier).
Actions menu: allows you to quickly insert a data field, text or currency symbol into a formula, open a
symbol table.

Formula text
The resulting text of the formula.
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Edit directly: when you click on the button, the formula will be available for editing as text.
You can add a comment to the formula as /*Your comment*/

12.2.10.1 Select Value window
The window is intended to select an initial value of a formula or a value of a function argument.
The window opens when you click the

Edit Expression button.

Appearance when you select an initial value of a formula

•

Type: type of initial value. Depending on the type, the way to select / type the initial value will
differ.

•

Negative: if the checkbox is set, then the sign of the initial value changes to the opposite one. If
this is a positive number, then it becomes negative and vice versa.

Appearance when you select a function argument value
If the window is open to select a value of a function argument, then the description of this argument
appears at the top of the window:
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Appearance when you select a Format function argument value
In this case, the window is used to customize the display format for numbers or dates:

Number
•

Decimal Point: a symbol that will separate the integer part from fractional.

•

Zero representation: the character to be used if the value of the number is zero.

•

Groups Separator: a symbol that will be used to divide groups (thousands, millions, etc.)
numbers.
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•

Show Leading Zeros: if the checkbox is set and the length of the integer specified by the
parameters of Number of Digits and Decimal Places is greater than the actual length of the integer
part of the displayed number, the number will be padded with zeros to the left to the specified
length of the integer part.

•

Display as: here you can specify in what form the number will be displayed:

◦ As Is: the number is displayed unchanged.
◦ Integer: only the integer part of the number is displayed.
◦ 2 Decimal Places: only 2 digits of the fractional part of the number are displayed.
◦ Integer and 2 Decimal Places: displays the integer part and only 2 digits of the fractional part
of the number.
◦ Other: you can specify the parameters for displaying the number:

▪ Number of Digits: the total number of digits of a number is the integer and fractional
parts.
▪ Decimal Places: the number of digits to display the fractional part of the number.
▪ In words: output as text in words.
Date and Time

•

Date and Time Format: format of the output date.
•

d: day without leading zero (1-2 digits);

•

dd: day with leading zero (2 digits);

•

M: month without leading zero (1-2 digits);

•

MM: month with leading zero (2 digits);

•

MMM: abbreviated name of the month;
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•

MMMM: the full name of the month;

•

yy: year 2 digits;

•

yyyy: year 4 digits;

•

h: hour without leading zero (1-2 digits);

•

hh: hour with leading zero (2 digits);

•

n: minutes without leading zero (1-2 digits);

•

nn: minutes with leading zero (2 digits);

•

s: seconds without leading zero (1-2 digits);

•

ss: seconds with leading zero (2 digits);

12.2.10.2 Function Select window
The window is used to select a function when replacing a function in a formula or when adding a function
to a formula.
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12.3

Product Catalog section

The section is designed to work with products that are stored in the internal database of the program.

12.3.1

Product List

This is a table with products and product parameters, such as prices, barcodes, SKUs, discounts, units,
etc.
The products can be placed in folders

. The level of nesting of folders is not limited.

Items can be in the normal state

or marked for deletion
. The same applies to folders.

Direct deletion of products from the database has been replaced with a deletion mark. Marking to delete
allows you to mark unnecessary products and folders for further removal from the program database. A
deletion mark can be canceled / set at any time.
Items marked for deletion can be deleted from the program database via the main menu of the program,
Delete Marked Elements.

12.3.1.1

Button for adding products to Print Data

Adds selected products / product groups to the Print Data.

12.3.1.2

Command Panel

The command panel allows you to perform various actions for a product or a group of selected products.
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Add: adding a new product

•
•

Import: import of products from an external data source (file, clipboard, database, etc.). How
to import data, see Data Importing.

•

: adding a new folder for products

•

: copying of product (creating a new product by copying an existing one)

•

: change of product / folder

•

: marking for deletion of product / folders

•

Search: search by various parameters of products

•

: cancel search

•

: search by product barcode

•

By print date: search for products by their printing date

•

: search for products changed after a certain date

12.3.1.3

Context menu

•

Move to Folder: moves the selected products / product groups to the selected folder.

•

Add products to the Print Data: adds selected products / product groups to the Print Data.

•

Add by scanning barcode: adding new products by scanning barcodes with a scanner

•

Barcodes: opens the window of the subordinate catalog Barcodes for the selected product
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•

Transparency codes: opens the window of the Transparency codes subordinate catalog for the
selected product

•

Genarate and add barcode: generates and adds a barcode to the selected products / product
groups using the settings from the Add barcodes section

12.3.1.4

Product image

In this area, the product image is displayed. You can add
image.

/ replace

, and also delete

the product

You can add an image using Drag & Drop.

12.3.1.5

Table Settings button

The Table Settings button is used to show the Table Settings window.

12.3.1.6

List view button

When the button is pressed, the products will be displayed in the form of a continuous list without folders.

12.3.1.7

Actions menu

The Actions menu is intended for adding selected items to Print Data, exporting products to a file
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12.3.2 Operations on selected lines (products and groups of
products)
In this section, mass operations are carried out on the selected products / groups of products.

12.3.2.1

Edit Prices

The section is intended for setting / changing the prices of products.
Prices of products can be formed on the basis of the same prices or other prices.
Prices are changed by adding / subtracting a percentage or specified value to the selected base.
•

Target Price: the price to be set / changed.

•

Source Price: the basis from which the price will be established.

•

Discount or Markup:
◦ Source of markup / discount

This can be a manually set numeric value or data from another column (if it contains numeric
data).
▪ Number: markup / discount in the form of a numerical value. A positive is an markup, a
negative is a discount:

▪ Column Value: the name of the column serving as a source of markup / discount:

◦ There will be an markup / discount in the form of a percentage or a certain value:
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•

Round: the accuracy of rounding the price received after the markup / discount:

To set / change prices, click the Replace button

12.3.2.2

Add Barcodes

The section is intended for adding barcodes of products. Barcodes are added to the catalog Barcodes
subordinate to this product.
•

Type: barcode type:

•

Prefix: barcode prefix.

•

Generate Using: the basis for the formation of a barcode:

•

Max Barcode Count per Product: the maximum number of barcodes that a product can have (0 unlimited). If this value is exceeded when creating barcodes for the products, then the barcode will
not be added to this product.

To add a barcode to the selected items / product groups, click the Add barcode...
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12.3.2.3

Replacing values in columns

The section is intended to replace / set values in a column.
•

Replace Value in Column: a column in which the values will change to the specified values.

•

With Text / With Number / With Value from Catalog...: text, numbers or value from the
catalog, respectively, which will be set in the column.

12.3.2.4

Replacing values in columns using formulas

The section is intended to replace / set values in a column using the formula.
•

Replace Value in Column: a column in which the values will change to the values returned by
the formula.

•

With the value returned by the formula: the formula.

12.3.2.5

Copy values from column to column

The section is intended to replace / set values in one column, using the values of the other column.
•

Replace Values in Column: a column in which the values will change to values from the other
column.

•

Copy Values from Column: the column that will be the source of the values.

12.3.3 Subordinate catalogs: Barcodes, Transparency codes,
Bundle Contents, Related Products
In these catalogs are stored data linked to the current product.
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To open the catalog, click on the appropriate name.
•

Barcodes: the catalog stores the product barcodes.

•

Transparency codes: the catalog stores the Amazon Transparency codes of the product.

•

Bundle Contents: the catalog stores the bundle of the products if the current product is a set of
several products.

•

Related Products: the catalog stores products associated with the current product.

12.4

Main menu of the program

Pressing the Menu will open the main menu of the program:

12.4.1

Catalogs submenu

This submenu provides access to all the program catalogs. Catalogs contain various background
information (units, brands, countries, users, etc.) that are used in the work. For example, in the product
catalog there is a Unit column that stores the unit of measure for a given product and this unit of measure
is taken from the Units catalog.

12.4.2

Menu item Delete Marked Items

When you click on this menu item, a window will be displayed for removing items marked for deletion
(products from the product catalog, catalog elements, label templates).

12.4.3

Menu item Settings

Clicking on this menu item will display the Program settings window.
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12.4.4

Tools submenu

This submenu allows you to perform various service operations.

12.4.5

Help submenu

•

User Guide: opens this user guide

•

Collect info for support: collects information for technical support of the program in the archive
for subsequent sending to the program support department

•

Write to Support: opens a form in the browser in support of the program

•

Leave Feedback: opens a form in the browser for writing a review of the program

•

Check for Updates: checks for updates to the program. If there is a new program update will be
offered to download it
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•

License Activation: opens a window for activation of the license (program)

•

About AzureLabel: opens a window in which information is displayed about the program, the
type of current license and its term. Also you can see the current users who work in the program
(for multi-user licenses), and the history of license (program) activations.

12.4.6

Language submenu

Selects the interface language.

12.4.7

Menu item Exit

When you click on this menu item the program will be closed.
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13 Printing from various systems
13.1

Print from EposNow BackOffice

13.1.1

Preparation for printing

13.1.1.1

In EposNow BackOffice

1. Go to the EposNow BackOffice, type "api" in the search place and click [Enter]

2. Click on the "REST API"
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3. Scroll down to the "Your API Devices"

4. Scroll to the right and click "Access credentials"

5. Copy "Authorization Token"

13.1.1.2

In AzureLabel

1. Run AzureLabel
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2. Go to Menu > Catalogs > External Data Sources

3. Duble click "Epos Now" or select "Epos Now" and press [Enter]
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4. Paste your copied Authorization Token into the appropriate field and click OK

5. Go to the Data Import > Settings for Import to Product Catalog tab and make the following
settings

6. Click OK
7. Go to the Product Catalog

8. Click on arrow on the right of "Import" button
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and click on Select a data source for One-click import
9. Select "EposNow" and click Select this External Data Source button

10. Click on arrow on the right of "Import" button

and click on One-click import...
Preparing for the data import is done. It's a one time operation.

azurelabel.com

119

13.1.2

Printing

Before printing, if necessary, synchronize data with EposNow. To do this, go to the product catalog and
click "Import"

, wait for the operation to complete.
How to print labels is described in the Printing Labels section.

13.2

Print from QuickBooks POS

13.2.1

Preparation for printing

13.2.1.1

In AzureLabel

1. Run AzureLabel
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2. Go to Menu > Catalogs > External Data Sources

3. Duble click "QuickBooks POS" or select "QuickBooks POS" and press [Enter]
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4. Go to the Data Import > Settings for Import to Product Catalog tab and make the following
settings

5. Click OK
6. Go to the Product Catalog

7. Click on arrow on the right of "Import" button

and click on Select a data source for One-click import
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8. Select "QuickBooks POS" and click Select this External Data Source button

9. Click on arrow on the right of "Import" button

and click on One-click import...

Preparing for the data import is done. It's a one time operation.

13.2.2

Export data from QuickBooks POS

1. In QuickBooks Desktop Point of Sale, go to File > Utilities > Export.
2. From the Data Export Wizard, select Inventory Items then Next.
3. Enter the needed data in the following fields: Select destination file - location where file will be
saved, Write records to (sheet) - worksheet where data must be entered, Begin exporting data
to row - row where data should be started
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4. From the Choose export template, you may select the default inventory template or manually
manage the mapping to match the details to be exported from QuickBooks Desktop Point of Sale.
5. Select Next.
6. Validate if the records ready for export is correct, then select Export.

13.2.3

Printing

Before printing, if necessary, synchronize data with QuickBooks POS. To do this:
1. Export data from QuickBooks POS
2. Go to the product catalog and click "Import"

, wait for the operation to complete.
How to print labels is described in the Printing Labels section.
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14 FAQ and How To
14.1

How to Print Amazon Transparency Codes

You can print Transparency codes in two ways, namely through:
1. Import Transparency codes into the program and then print labels with imported codes.
How to do this will be described below.
2. Printing labels with Transparency codes, transferring data to the program directly from another
system / program.
You can see how to do this in the Integration Guide
The program remembers each printed Transparency code in the Printed Transparency codes catalog. A
label already printed with a Transparency Code will not be printed or displayed in a preview, thus
avoiding duplicate printing of Transparency codes.

14.1.1

Importing Transparency codes into the program

You must first request your Transparency codes from Amazon. These codes are delivered in a CSV file
and are listed in the "Public_Code" column. You can get more information directly from Amazon.
1. Go to Label Printing:

2. Clear the product list with the clear button:

3. Click the Import button:
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4. Select Amazon Transparency codes data source:

If your Transparency codes are in a file of a different format, then you can use another data source,
for example Spreadsheet (Excel, ODF etc) and, accordingly, import Transparency codes from
Excel files.
5. Click the Read Data from Source button
6. Go to the Import Data tab:

7. Make sure that the column with Transparency codes is bound to the data field Transparency
code:

If not, click on the column header with the Transparency codes and select the Transparency code
data field.
8. Click the Import Data button and close the import window
After importing the Transparency codes into the program, you can print labels with the imported codes.
You can see more details about importing into the program in the Importing Data section.
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14.1.2

Printing labels with Transparency codes

For printing 1 Transparency codes, templates are supplied with the program:
•

Amazon Transparency 1.125" x 1.125"

•

Amazon Transparency 1.75" x 0.75"

•

Amazon Transparency UPC 1.375" x 1.375"

1. Select one of the above label template:

2. Click the Print or Preview button to print labels with Transparency codes:

Example of printed labels (test data):
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You can change these templates for yourself in the Label Designer.
1

For more details on how to print labels, see the Printing Labels section.

14.2

How to delete products from catalog?

1. Select the items / folders that you want to delete and click Mark For Deletion
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The icons of these items / folders will change to those marked for deletion.

2. In the program menu, click on Delete Marked Items

14.3 How to display a link from the database in a QR
code?
Suppose that you are importing links into the Parameter 1 column. Then you need to display the data
from this column in a QR code.
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14.3.1

At the time of inserting the QR code into the template

1. Go to the Data source for barcode tab

2. Select data field Parameter 1
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14.3.2

In an existing QR code

1. Double click on the QR code

2. Select data field Parameter 1

3. Click OK
4. Save the template

14.4

How to generate barcode?

You can do this in two ways.

14.4.1

In the product catalog

1. Select desired products or folders
2. Click Actions with Selected Rows at the bottom of the window
3. Go to the Add Barcodes tab
4. Set the parameters for forming barcodes (type of barcode, prefix, on the basis of which the
barcode will be formed)
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5. Click Add barcode in selected products button

14.4.2

In the template formula

Use function Barcode
For example formula
[ProductCode] Barcode("EAN-13"; "23")
will generate an EAN-13 barcode with the prefix "23" based on the product code.
In this case, the barcode will be formed "on the fly" when printing labels or in print preview.

14.5 How to change the currency symbol in the
label?
Open Label Designer, delete the old currency symbol and add the desired currency symbol with the
Currency Symbol tool:

14.6

How to bind templates to products?

To bind a template to a product, select the product and set the desired template in the Template column

14.6.1

If you need to bind a template to several products at once

1. Select desired products or folders
2. Click Actions with Selected Rows at the bottom of the window
3. Go to the Replace Values in column tab
4. In the Replace values in column field, select the Template column
5. Select the required template in the With Value from catalog "Templates" field
6. Click Replace "Template"in selected products button
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14.7 How to make sure that when adding a new
product in the Country column the manufacturer I
need is put?
1. Go to the Menu > Settings
2. Go to the Catalogs section
3. Select Countries catalog
4. Select desired country in the Default value field
This country will be used by default for new products.
Similarly, you can specify default values for other catalogs.

14.8 How to sort products? How to sort products by
several columns, for example, by article and color?
You can sort the list by any column, for example, by name, article number, etc.
To sort, click on the column heading.
To change the sort direction, click on the column heading again.
To sort by several columns, press the [Ctrl] key while clicking on the column heading

14.9

How to make a discount or markup?

To make a markup or discount:
1. Open product catalog
2. Click Actions with Selected Rows at the bottom of the window
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3. Go to the Edit Prices tab
4. Select desired products
5. Select the price to set in Target Price.
The price will be set in this way: the base price will be taken, a discount or markup will be applied
to it, then rounding will be performed, of the price received
6. Select the base price in Source Price, which serves as the basis for the discount or mark-up.
This can be a same price that Target Price, if you need to change a certain price by a number or
percentage
7. Select the source of the discount / markup: a number or value from the column of the product
catalog
8. If this is a number, then specify the desired one.
Positive number - markup, negative number - discount
9. Choose the type of markup / discount - percentage or unit of currency
10. Choose rounding
11. Click Replace...

14.10 How to use image links in Google Drive to
display images in labels?
Google Drive public links of this kind
https://drive.google.com/file/d/{ID изображения}/view?usp=sharing
not suitable for direct image acquisition.
Such links must be converted to links of this kind
https://drive.google.com/thumbnail?id={ID изображения}&sz=w{Ширина изображения в
пикселях}
You can do the conversion directly in the template. For this, it is necessary to add the function of
replacing part of the string in the formula for obtaining a link to an image.
An example of a formula if the link to the image is obtained from the data field [ProductParam1] (column
"Parameter 1") and the image width should be 1000px:
[ProductParam1] Replace("/file/d/"; "/thumbnail?id=" ; "T") Replace("/view?usp=sharing";
"&sz=w1000" ; "T")
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14.11 How to add an element, such as a barcode, to a
separate layer in a template?
There are 9 layers in the template. By default, all elements are added to layer 1. Before adding, you can
change the current layer to another by changing All layers to Layer 2 in the right part of the designer, for
example

and then add the element.
You can also change the layer in an element properties on the Size and Position tab in the Layer field for
an existing element.

14.12 How to create your own label template?
Creating a label template is described in the Creating a label template section.

14.13 How do I transfer a label template or multiple
templates to another computer?
14.13.1 To transfer one template
1. Go to Label Designer
2. Select Actions > Save to file menu
3. Choose a location to save the template
4. Transfer the saved template to another computer
5. On another computer, go to Label Designer
6. Select Actions> Load from file menu
7. Select a saved template

14.13.2 To transfer multiple templates
1. Go to Label Designer
2. Click on the button All templates
3. Check the boxes for the templates or template folders you want
4. Select Actions > Templates export menu
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5. Select the templates export method "Keep folder structure"
6. Select a folder to save templates
7. Transfer the folder with the saved templates to another computer
8. On another computer, go to Label Designer
9. Click on the button All templates
10. Go to the root of the catalog

11. Select Actions > Templates import menu
12. Select the import method "Import all templates from a folder"
13. Select a folder with saved templates

14.14 How to work with GS1 data in a label template?
To work with GS1, you can use:
1. The function in the formula GetGS1ParsedData(<AI>), where <AI> is the AI by which the
function returns the data of the element if an element with such AI was present in the GS1 string,
otherwise the function returns an empty string
2. The functions in a Pascal script GetGS1ParsedData(<GS1 string>, <AI>), where <GS1 string>
is the GS1 string that the function parses into separate elements, <AI> is the AI by which the
function returns the data of the element if an element with such AI was present in the GS1 string,
otherwise the function returns an empty string.
The full list of elements that can be stored by the GS1 string and which you can get through AI, you can
look at the link https://www.gs1.org/standards/barcodes/application-identifiers?lang=en
An example of working with GS1 data using a formula in which:
1. GS1 string is taken from the Barcode data field
2. Using the GetGS1ParsedData function, the GTIN (AI = 01) is obtained from the GS1 string and
displayed in the label
[Barcode] GetGS1ParsedData ("01")
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An example of working with GS1 data using a Pascal script in which:
1. GS1 string is taken from the Barcode data field
2. Using the GetGS1ParsedData function, the GTIN (AI = 01), Serial (AI = 21) are obtained from
the GS1 string and displayed in the label
var
GS1Str, GTIN, Serial: string;
begin
//getting GS1 string from Barcode parameter
GS1Str := GetParam('Barcode');
//getting GTIN (AI = 01) from parsed data
GTIN := GetGS1ParsedData(GS1Str, '01');
//getting Serial (AI = 21) from parsed data
Serial := GetGS1ParsedData(GS1Str, '21');
WriteLn('GTIN:');
//displaying GTIN
WriteLn(GTIN);
WriteLn('Serial: ');
//displaying Serial
WriteLn(Serial);
end.

14.15 How to import GTIN and other elements from
the input GS1 string?
Suppose you have a file with products and each product has a corresponding GS1 string.
Consider two options for importing this file:
1. You want to import instead of the GS1 string a GTIN * element that should be selected from this
string
2. You want to import both the GS1 string and the GTIN * element that should be selected from this
string
* Or any other element or several elements

14.15.1 Implementing Option 1 (import GTIN only)
Suppose you want to import a GTIN element into the Parameter 2 data field.
Initial setting:
1. Open data source settings
2. Go to the Data fields tab
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3. Select data field Parameter 2
4. Go to the Settings of Import / Print from Source tab
5. Set the formula to get the GTIN value (AI = 01):
[ProductParam2] GetGS1ParsedData("01")

Before importing, bind the column containing the GS1 to the Parameter 2 data field:

After importing, the Parameter 2 data field will show the GTIN selected from the GS1 line. In this
example, this is "04999123456789":

How it works? When importing from GS1 the string passed to the Parameter 2 data field, the GTIN is
extracted using the formula and its value replaces the current value of the Parameter 2 data field.
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14.15.2 Implementing Option 2 (import GS1 strings and GTIN)
Suppose you want to import a GS1 string into the Parameter 1 data field, and a GTIN element into the
Parameter 2 data field.
Initial setting:
1. Open data source settings
2. Go to the Data fields tab
3. Select data field Parameter 2
4. Go to the Settings of Import / Print from Source tab
5. Set the formula to get the GTIN value (AI = 01):
[ProductParam1] GetGS1ParsedData("01")

Before importing, bind the column containing the GS1 to the Parameter 1 data field:

After importing, the GS1 string will appear in the Parameter 1 data field, the GTIN selected from the
GS1 row will appear in the Parameter 2 data field. In this example, this is "04999123456789":

azurelabel.com

139

How it works? When importing from GS1 the string passed in the Parameter 1 data field, GTIN is
selected using the formula and its value falls into the Parameter 2 data field.

14.16 How to duplicate the price with extra charge
during import?
Suppose you have a file with products and each product has a price, but you want to import this price with
a mark-up.
Initial setting:
1. Open data source settings
2. Go to the Data fields tab
3. Select Parameter 2 data field
4. Go to the Settings of Import / Print from Source tab

azurelabel.com

140

5. Set the formula to get the price value with a mark-up (in this example, 15%):
[ProductPrice] AddPercent(15;"+")

Before importing, bind the column containing the price to the Price data field:

After import, in the Price data field there will be a price with a margin of 15%. In this example, it is
"115":

How it works? When importing, the price passed in the Price data field is charged by 15% using the
formula and replaces the current value in the Price data field.
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14.17 How to configure import to the product catalog
on schedule?
1. Create and configure a task for import in the Tasks catalog
2. Configure Windows Scheduler to run this task

14.17.1 Task creation
1. Open the Tasks catalog through Menu > Catalogs > Tasks
2. Create a task using the Add button
3. Set the task type to Import and the data source (in this example, the Spreadsheet)

4. Configure the data source in the same way as described in the One-Click Import
section. You can open the data source settings directly from the task:

azurelabel.com

142

14.17.2 Configure Windows Scheduler to run this task
1. Go to the Windows menu Start > Windows Administrative Tools > Task Scheduler:

2. Click Create Task:
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3. Go to the Actions tab and click New:

4. Click Browse and select the program file "C: \ Program Files (x86) \ AzureLabel 11\
AzureLabel.exe":

azurelabel.com

144

azurelabel.com

145

5. Temporarily go to the program and in the task window click Copy as arguments to run from the
command line:
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6. Paste the copied into the Add arguments box:

7. Click ОК
8. Go to the Triggers tab and click New:

9. Set the task launch schedule
This completes the configuration and the Windows task scheduler will start importing into the product
catalog according to the schedule you set.
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See when the task was launched, whether it was successful and the result of its execution you can in the
Tasks catalog:

14.18 Pascal script examples
To use the script from the example:
1. In the template, open Element Properties
2. On the Data Source tab, set the type to Pascal Script
3. Paste the script text from the example
4. Click OK

14.18.1 How to make sure that only the first 3 words are displayed
from the product name?
Script text:
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var
p, delim, curWord, outStr: string;
i, n, maxWords: integer;
begin
p:= GetParam('ProductName'); //getting product name
maxWords:= 3; //maximum number of words
delim:= ', :;().'; //word delimiter string
outStr:= ''; //resulting string
n:= 0;
curWord:= '';
for i := 1 to length(p) do
begin
outStr:= outStr + p[i];
if pos(p[i], delim) = 0 then
curWord:= curWord + p[i]
else
begin
if length(curWord) = 0 then
continue;
curWord:= '';
inc(n);
if n >= maxWords then
break;
end;
end;
Write(outStr);
end.
To change the maximum number of displayed words, search the text
"maxWords: = 3;" and replace the number 3 with another.

14.18.2 How to make the product name displayed only up to a
comma?
Script text:
var
p, delim, outStr: string;
n: integer;
begin
p:= GetParam('ProductName'); //getting product name
delim:= ',';
n:= pos(delim, p);
if n = 0 then
outStr:= p
else
outStr:= copy(p, 1, n - 1);
Write(outStr);
end.
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